Support Contact Us Issues
Incident Report for Eventbrite
Resolved
This issue has been resolved
Posted Jun 11, 2022 - 10:30 PDT
Identified
We've identified an issue where certain customers are unable to contact our customer support teams as expected. We have our technical team working to release a fix to the issue as soon as possible. We appreciate your patience in the meantime. For the answers to most common questions, please visit eventbrite.com/support
Posted Jun 10, 2022 - 15:45 PDT
This incident affected: Help Center & Support.