Contact page connectivity issues
Incident Report for Eventbrite
Resolved
This incident has been resolved.
Posted Jul 01, 2023 - 07:08 PDT
Investigating
We’re experiencing site issues that affect our contact page. Our technical team is working to fix this as soon as possible. We apologize for any inconvenience and appreciate your patience
Posted Jul 01, 2023 - 06:47 PDT