Google Cloud outage causing images to not display.

Incident Report for Eventbrite

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 14:42 PDT

Identified

An issue with Google Cloud infrastructure is causing some images to not display properly on our site. This outage may have other impact to our site, applications, partners, and other sites across the internet. We will continue to monitor that incident (below) and update this page as things develop.

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
Posted Jun 12, 2025 - 13:15 PDT